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Overview
The NetIQ Aegis Adapter for EMC Smarts (Smarts adapter) allows the automation of run books and 
broader processes in EMC Smarts from your NetIQ Aegis Console. 

The Smarts adapter includes a library of workflow activities specific to EMC Smarts that Process Authors 
can use in the Workflow Designer.

For more information about activities or activities libraries, see the Process Authoring Guide for Aegis.

Product Requirements
The Smarts adapter requires the following software versions:

• Aegis 2.2

• EMC Smarts 7.04 and EMC Ionix 8.1

• Microsoft .NET Framework 2.0

One of the following operating systems:

• Windows Server 2003 Service Pack 2 or later (32-bit)

• Windows Server 2008 Service Pack 2 or later (32- and 64-bit)

• Windows Server 2008 R2

This version of the Smarts adapter does not support upgrading from any previous version. You must 
uninstall any previous version of the adapter before you install this version.

Implementation Overview
The following table provides an overview of tasks to configure the Smarts adapter. 

Steps For more information, see…
1. Configure the minimum rights and 

privileges for installing the Smarts adapter.
“Ensuring Minimum Rights and Privileges” on 
page 2

2. Install the Smarts console on the Aegis 
Server computer.

“Installing the Smarts Console on the Aegis 
Server” on page 2

3. Install the Smarts adapter.
“Installing the Smarts Adapter” on page 2

4. Install the Event Renderer on the Web 
Server computer.

“Installing the Event Renderer” on page 3

5. Configure the Smarts Adapter.
“Configuring the Smarts Adapter” on page 4

6. Configure a new Smarts Server.
“Configuring a New Smarts Server” on page 4

7. Configure the License Assignment
“Configuring the License Assignment” on page 4
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Ensuring Minimum Rights and Privileges
Before installing the Smarts adapter, ensure the user who installs the adapter has the following minimum 
rights and privileges:

• Privileges to change/create the values of the files they want to update or create.

• Assigned to the admin profile in the Smarts environment.

Installing the Smarts Console on the Aegis Server
Before you install the Smarts adapter, you must install the Smarts console on the Aegis Server computer. 
The Smarts console includes the Smarts API, which the Smarts adapter installation program requires to 
verify credentials for the broker and Domain Manager(s) available in the Smarts environment.

For more information about installing the Smarts console, see the appropriate documentation for EMC 
Smarts.

Installing the Smarts Adapter
The Smarts adapter allows Aegis to communicate with EMC Smarts, and allows Process Authors to add 
Smarts activities to an Aegis workflow. You must install the Smarts adapter on the Aegis Server computer. 
For more information about installing Aegis, see the Administrator Guide for Aegis. 

If your Aegis server computer is part of a cluster, you must install the Smarts adapter on each node in the 
cluster. The installation program automatically detects whether the node is active or passive. The Smarts 
adapter needs to be installed with the same feature set selected, on both the Aegis active node and all the 
Aegis passive nodes.

To install the Smarts adapter on the Aegis Server computer:

1. Log on to the Aegis Server computer with a local administrator account.

2. Run the setup program from the folder where you downloaded the Smarts adapter.

3. Click Next.

4. Accept the license agreement, and then click Next.

8. Configure the Domain Manager 
Information.

“Configuring the Domain Manager Information” 
on page 5

9. Verify the installation was successful.
“Verifying a Successful Installation” on page 5

Steps For more information, see…
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5. If the Aegis Server and Web Server are on the same computer in your Aegis environment, on the 
Select Components window, select the following options:

• Smarts Adapter

• Event Renderer and Parsers

6. If the Aegis Server and Web Server are on separate computers in your Aegis environment, on the 
Select Components window, select Smarts Adapter.

For more information about installing the event renderer on a separate Web Server computer, see 
“Installing the Event Renderer” on page 3.

7. On the Logon Information page of the installation wizard, complete the following steps:

a. If the Aegis Server computer is not part of a cluster environment, verify the Aegis Server 
computer name or IP address and the server port.

b. If the Aegis Server computer is part of a cluster environment in the active node, verify the 
cluster name or IP address and the server port.

c. Specify the logon credentials for the Aegis service account. If you do not know the logon 
credentials for the Aegis service account, contact your Aegis administrator.

d. If the Aegis Server computer belongs to a domain, ensure you specify the correct domain.

e. Click Next.

8. Click Next.

9. Follow the remaining instructions in the NetIQ Aegis Adapter for EMC Smarts Setup wizard, and 
then click Finish.

Installing the Event Renderer
The event renderer for the Smarts adapter provides rendering functionality for the layout of Smarts event 
details in the Operations Console.

If your Web Server computer is part of a cluster, you must install the event renderer on the active node 
first, and then on each passive node. 

To install the event renderer on the Web Server computer:

1. Log on to the Web Server computer with a local administrator account.

2. Run the setup program from the folder where you downloaded the Smarts adapter.

3.  Click Next

4. Accept the license agreement, and then click Next.

5. On the select components window, select Event Renderer, and then click Next.

Follow the remaining instructions in the NetIQ Aegis Adapter for EMC Smarts Setup wizard, and then 
click Finish.
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Configuring the Smarts Adapter
When the installation is complete, the Aegis Adapter Configuration Utility allows you to configure the 
following: 

• A new Smarts server

• License assignment

• Domain Manager information 

Configuring a New Smarts Server
Using the Aegis Adapter Configuration Utility, you can add a new Smarts server at any time. You can 
also specify the Smarts class names with instances you want to represent as computers in the Resource 
Management databases. 

To configure a new Smarts server:

1. In the NetIQ program group, click Aegis > NetIQ Aegis Adapter Configuration Utility.

2. In the left pane, click EMC Smarts Adapter.

3. On the Edit menu, click New Entry.

4. Provide the appropriate information, and then click Save All.

5. Restart the NetIQ Aegis Namespace Provider service.

Configuring the License Assignment
Using the Aegis Adapter Configuration Utility, you can configure the license assignment for the Smarts 
adapter. The Smarts adapter licensing defines a Smarts System as an environment with one Domain 
Manager Broker and any number of Domain Managers. The Smarts adapter currently enforces 
licensing on a “per system” basis, which requires one license for each active Domain Manager Broker.

If you have more than one Smarts environment, you can configure the order in which the available 
licenses are assigned. 

To configure the license assignment:

1. In the NetIQ program group, click Aegis > NetIQ Aegis Adapter Configuration Utility.

2. In the left pane, click EMC Smarts Adapter.

3. Under Licensing Order, click the Smarts server for which you wish to sort the license assignment, and 
then specify the order in which to assign the license.

4. On the File menu, click Save All.

5. Restart the NetIQ Aegis Namespace Provider service. 
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Configuring the Domain Manager Information
A Smarts environment can include multiple Domain Managers with which the Smarts adapter can 
communicate. To allow the Adapter to interact and receive events, you must enable the Monitored 
parameter

The following information is provided by the Smarts Broker and is not editable:

• Domain Manager host name

• Domain Manager name

• Domain Manager port

To configure the domain manager: 

1. In the NetIQ program group, click Aegis > NetIQ Aegis Adapter Configuration Utility.

2. In the left pane, click the Domain Manager you wish to configure.

3. Provide the appropriate user information for your environment. 

4. To configure when Aegis receives event notifications, select one of the following options:

• Listen Topology Events - Aegis receives event notifications when Domain Manager objects are 
added or removed, or when a link between them changes.

• Listen Object Events - Aegis receives event notifications when the Domain Manager detects an 
abnormal situation in the objects it monitors. You can also restrict the class and instance, the 
events in which you are interested, and events types (events, problems, and event aggregations). 

• Listen Property Updated Events - Aegis receives event notifications when the Domain Manager 
detects changes to the properties of the objects it monitors. You can also restrict the class ranges, 
instances, and properties.

• Listen Notification Events - Aegis receives event notifications when the Domain Manager detects 
new, updated, or deleted values for a notification attribute, or when the state for a notification 
attribute changes. This option is available only if the selected Domain Manager is also a Global 
Manager. 

5.  On the File menu, click Save All.

6. Restart the NetIQ Aegis Namespace Provider service.

Verifying a Successful Installation
Once you install the Smarts adapter, you can verify whether your installation was successful with the 
following steps:

1. Start the Aegis Configuration Console. 

For more information about starting the console configuration, please see the Administrator Guide for 
Aegis.

2. In the Navigation pane, click Administration.

3. In the left pane, click Namespace Browser.

4. In the namespace tree, expand JSIQSMARTS > JSIQSMARTS_System > Smarts Server > 
JSIQSMARTS_DomainManager.

5. Ensure you see the Domain Managers you configured during the installation process.
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After verifying a successful installation, NetIQ recommends you build a simple worflow with one of the 
activities in the Smarts Adapter library. For more information about building workflows, see the Process 
Authoring Guide for Aegis.

Workflow Activities Overview
The activities in the Smarts Adapter Library allow Aegis to perform the following types of tasks:

• Obtain detailed information about notifications, their related objects, and the events which cause 
them.

• Update notifications.

• Notify and clear notification events.

• Look for Smarts Objects and recover their attributes and relations.

• Create, update, rediscover, manage/un-manage, and remove Smarts objects.

• Initiate Smarts object operations.

• Initiate tasks in the Domain Managers, such as discovering new devices, codebook correlation tasks, 
and executing tools. 

Uninstalling the Smarts Adapter
You can uninstall the Smarts adapter using Add/Remove Programs in Windows Control Panel.

If you are uninstalling from a cluster environment, ensure the following:

• Uninstall the adapter from all passive nodes first.

• Remove the node from the cluster before you uninstall the adapter.

Data Type Mappings
The following table describes the mapping of Smarts to Aegis data types.

Smarts Internal 
Type

Smarts Type Aegis Type Description

SM_BOOLEAN boolean BOOL A boolean value

SM_INT int SINT32 32-bit integer

SM_UINT unsigned-int UINT32 32-bit unsigned integer

SM_LONG long SINT64 64-bit integer

SM_ULONG unsigned-long UINT64 64-bit unsigned integer

SM_SHORT short SINT16 16-bit integer

SM_USHORT unsigned-short UINT16 16-bit unsigned integer

SM_FLOAT float FLOAT 32-bit IEEE floating-point
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SM_DOUBLE double DOUBLE 64-bit IEEE floating-point

SM_CHAR char STRING 8-bit native character

SM_STRING string STRING 32-bit pointer to NULL-terminated character string.

SM_OBJREF relationship ATTRLIST Represents an object in the Domain Manager repository. An object 
in the Domain Manager repository is uniquely identified by its class 
name and its name. The Aegis attribute list created to represent 
this data type will contain two attributes:
-ClassName (string), for example a Switch
-InstanceName (string), for example a Core Switch

SM_BOOLEAN_SET boolean set BOOL_ARRAY Set of booleans

SM_INT_SET int set SINT32_ARRAY Set of 32-bit integers

SM_UINT_SET unsigned-int-set UINT32_ARRAY Set of 32-bit unsigned integers

SM_LONG_SET long set SINT64_ARRAY Set of 64-bit integers

SM_ULONG_SET unsigned-long-
set

UINT64_ARRAY Set of 64-bit unsigned integers

SM_SHORT_SET short set SINT16_ARRAY Set of 16-bit integers

SM_USHORT_SET unsigned-short 
set

UINT16_ARRAY Set of 16-bit unsigned integers

SM_FLOAT_SET float set FLOAT_ARRAY Set of 32-bit floats

SM_DOUBLE_SET double set DOUBLE_ARRAY Set of 64-bit floats

SM_CHAR_SET char set STRING_ARRAY Set of characters

SM_STRING_SET string set STRING_ARRAY Set of strings

SM_OBJREF_SET relationship set TABLE Represents a set of objects in the Domain Manager repository.
The Aegis table used to map this Smarts data type will define one 
row for each object included in the object set, each row will contain 
an attribute list defining two attributes:
- className (string)
- instanceName (string)
For example:
ClassName Switch  InstanceName Core Switch
ClassName Port      InstanceName MC1/0

SM_ANYVALARRAY structure set TABLE A Smarts SM_ANYVAL type is an object that can hold different 
types. An SM_ANYVALARRAY is an array (set) of SM_ANYVALs.
This Smarts type will be mapped to a Table where each row will 
contain an attribute list defining three attributes:
- type (string)
- index (int)
- value (Value)

For example:

Type  SM_BOOLEAN  Index  0  Value True
Type  SM_STRING      Index  1  Value  “Some Text”
Type  SM_INT_SET     Index  2  Value  [4,7,6,7,5]

Smarts Internal 
Type

Smarts Type Aegis Type Description
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SM_ANYVALARRAY
_SET

structure set TABLE A Smarts SM_ANYVALARRAY_SET is a set of 
SM_ANYVALARRAYs.
This Smarts type will be mapped to a Table where each row will 
contain an attribute list defining three attributes:
- type (string) will be “SM_ANYVALARRAY”
- index (int)
- value (table) a table with the same structure used to map the 
SMANYVALARRAY Smarts type

For example:

Type  SM_ANYVALARRAY  Index 0
Value
         Type  SM_FLOAT      Index  0  Value  0.5
         Type  SM_STRING    Index  1  Value  “Some String”

Type  SM_ANYVALARRAY  Index 1
Value
         Type  SM_BOOLEAN Index  0  Value  True
         Type  SM_INT            Index  2  Value  125

Smarts Internal 
Type

Smarts Type Aegis Type Description
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